【Linux Mint】Gim2.8 インストールできない

スポンサーリンク

Gimp2.8の正式版がリリースされました

というわけで、Linux Mintでも使いたいという欲求があるわけですが、
どうもLinux Mint13を待たなければならない?ようです。

2012年6月21日追記

Linux mint13でのインストールを確認しました。
下記の記事からどうぞ。
http://linux-kotohajime.blogspot.jp/2012/06/linux-mintgimp.html

2012年6月8日追記:現状 Linux Mint 13でもPPAは2.6のまま。
debian のテストPPAからインストールできそうですが・・・。
参考記事はこちらで。
http://linux-kotohajime.blogspot.jp/2012/05/linux-mint-debiagimp28.html

Linux Mintのフォーラムでも一応、インストールの方法が掲載されていますが、
しかし、この方法だとトラブルが起きているようです。
一応、インストールできる方法としては、以下の手順が記載されています。
sudo apt-get purge Gimp*
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update

真ん中の行のppaを追加すると、インストールできるようになるよとのことですが、
どうもこの方法では上手く行かない方が多いようです。

フォーラムの中でも次のようなエラーが出ると報告されています。

The following packages have unmet dependencies:
gimp : Depends: libgimp2.0 (>= 2.8.0-1ubuntu0ppa3~oneiric) but it is not going to be installed
        Depends: libgimp2.0 (<= 2.8.0-z) but it is not going to be installed
        Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.6-0ubuntu5linuxmint1 is to be installed
E: Unable to correct problems, you have held broken packages.

日本語版のエラーだと、

以下のパッケージには満たせない依存関係があります:
 gimp : 依存: libgimp2.0 (>= 2.8.0-1ubuntu0ppa4~oneiric) しかし、インストールされようとしていません
        依存: libgimp2.0 (<= 2.8.0-z) しかし、インストールされようとしていません
        依存: libgtk2.0-0 (>= 2.24.10) しかし、2.24.6-0ubuntu5linuxmint1 はインストールされようとしています
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

といった感じです。

また、上記のPPAを入れてしまうと、旧バージョンの2.6もインストールが出来なくなて
しまうため、上記の指示にしたがって2.6をインストールするとGimpがインストール
できなくなります。

フォーラム内にも掲載されていますが、以下、解決方法です。

PPAを削除する必要があるため、まずは、「ppa-purge」をインストールします。

sudo apt-get install ppa-purge
sudo ppa-purge ppa:otto-kesselgulasch/gimp
sudo apt-get update

これで、PPAを削除します。削除できたら、念のためGmpをもう一度削除してか
インストールします。

sudo apt-get purge Gimp*
sudo apt-get install gimp

で削除できます。


Linux Mintフォーラム(英語)http://forums.linuxmint.com/viewtopic.php?f=47&t=101517&start=0

スポンサーリンク

シェアする

フォローする

スポンサーリンク